Chargement...
Allez viens, on est bien !
Inscription / Connexion :
Google
Nouveaux Populaires Likes Favoris
plus
Tous les groupes Créer un groupe



[Excel Master] Automatisation de cellules en fonction de choix déroulants

Salut les chouals,

Aujourd'hui j'ai encore un souci qui a priori est léger, mais je galère à formuler ce que je recherche avec Google..

J'ai mis en place un choix déroulant à 3 choix Small / Medium / Large en colonne A
Je voudrais que en colonne B, sur la cellule à côté s'affiche directement un nombre si c'est le choix Small, ou un autre si c'est le choix Medium, ou un autre si c'est le choix Large.

En l'occurence, si je choisis Small, alors la cellule à côté affiche 25 // si je choisis Medium >> 50 // Choix Large >> 75.

A partir de ça je pourrais mettre en place des calculs automatiques etc.. mais je bute ici et je sais que la formule que la formule que je cherche n'est pas sorcière pour un Excel Masta.

Des bisous, merci !
Connectez-vous ou ouvrez un compte pour poster un commentaire.
Ben tu fais un simple si ....
=si(A1="SMALL";"TA VALEUR";si(A1="medium";"prout caca";"ta valeur pour large"))
Martos
op
@boulbi: Ah bah voilà, il me manquait les " " autour de Small / Medium / Large :B

MERCI ♥
@Martos: Oui il faut mettre des " " entre les valeurs non numérique, un peu comme partout.
Un peu bourrin mais fonctionne (Choualbox nique les formules)

https://image.noelshack.com/fichiers/2019/34/5/1566547715-bourrin.jpg

EDIT: Voici la méthode "clean"

https://www.noelshack.com/2019-34-5-1566547904-clean.png
@Pouki: Tu te compliques la vie : la valeur si faux est la réponse à renvoyer de ton dernier test : ici la réponse pour "large", ton dernier test est donc inutile.
@boulbi: C'est plus pour l’intérêt pédagogique que je l'ai mis, et si après il veut complexifier la formule...
Martos
op
@Pouki: Merci ! ♥
Et si tu mets une liste de correspondance dans une autre feuille (que tu peux rendre invisible) du genre tu mets Small Medium Large en A1, A2, A3 et les valeurs 25, 50, 75 en B1, B2 et B3 respectivement.
Tu sélectionnes ces 6 cellules que tu nommes "corresp" par exemple.
Il te suffit alors dans ta page où tu veux ton automatisme d'écrire en B2 par exemple :
= RECHERCHEV($A2;corresp;2;Faux) et tu recopies ta formules jusqu'où tu veux.

Le gros avantage c'est que tu peux modifier les noms, les valeurs en un seul endroit.

https://www.noelshack.com/2019-34-5-1566549727-corresp.png



A Voir
Chargement...
Chargement...
Chargement...